9702 C# Programming Manual: D:/9702/C# Directory Reference

9702 C# Programming Manual
C# Directory Reference

Files

file | JYPXIe9702AOTask.cs
file | JYPXIe9702DITask.cs
file | JYPXIe9702DOTask.cs
Generated by doxygen 1.9.1


9702 C# Programming Manual: D:/9702/C#/JYPXIe9702AOTask.cs File Reference

Classes | Namespaces | Enumerations
JYPXIe9702AOTask.cs File Reference

Classes

class | JYPXIe9702.JYPXIe9702AOTask
JY9702 Analog ouput Task More...
class | JYPXIe9702.AOChannel
AO Channel parameter class . More...
class | JYPXIe9702.DDSConfig
DDS waveform configuration class. More...
class | JYPXIe9702.AOAdvanced
AO Advanced parameters More...
class | JYPXIe9702.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYPXIe9702.AODigitalTrigger
AO Digital trigger . More...
class | JYPXIe9702.AOSignalExport
AO Signal Export Class More...
class | JYPXIe9702.AISync
Configure sync signal More...

Namespaces

namespace JYPXIe9702

Enumerations

enum class | JYPXIe9702.AODigitalTriggerEdge { JYPXIe9702.Rising = JYPXIe9702Import.Rising_Edge_Trigger , JYPXIe9702.Falling = JYPXIe9702Import.Falling_Edge_Trigger , JYPXIe9702.High = JYPXIe9702Import.High_Level_Trigger , JYPXIe9702.Low = JYPXIe9702Import.Low_Level_Trigger }
AO Digital Trigger Edge More...
enum class JYPXIe9702.AODigitalTriggerSource {
JYPXIe9702.TRIG_IN = JYPXIe9702Import.TriggerIn , JYPXIe9702.PFI0 = JYPXIe9702Import.PFI_0_IN_0 , JYPXIe9702.PFI1 = JYPXIe9702Import.PFI_0_IN_1 , JYPXIe9702.PFI2 = JYPXIe9702Import.PFI_0_IN_2 ,
JYPXIe9702.PFI3 = JYPXIe9702Import.PFI_0_IN_3 , JYPXIe9702.PFI4 = JYPXIe9702Import.PFI_0_IN_4 , JYPXIe9702.PFI5 = JYPXIe9702Import.PFI_0_IN_5 , JYPXIe9702.PFI6 = JYPXIe9702Import.PFI_0_IN_6 ,
JYPXIe9702.PFI7 = JYPXIe9702Import.PFI_0_IN_7 , JYPXIe9702.PXI_Trig0 = JYPXIe9702Import.PFI_PXI_Trig_IN_0 , JYPXIe9702.PXI_Trig1 = JYPXIe9702Import.PFI_PXI_Trig_IN_1 , JYPXIe9702.PXI_Trig2 = JYPXIe9702Import.PFI_PXI_Trig_IN_2 ,
JYPXIe9702.PXI_Trig3 = JYPXIe9702Import.PFI_PXI_Trig_IN_3 , JYPXIe9702.PXI_Trig4 = JYPXIe9702Import.PFI_PXI_Trig_IN_4 , JYPXIe9702.PXI_Trig5 = JYPXIe9702Import.PFI_PXI_Trig_IN_5 , JYPXIe9702.PXI_Trig6 = JYPXIe9702Import.PFI_PXI_Trig_IN_6 ,
JYPXIe9702.PXI_Trig7 = JYPXIe9702Import.PFI_PXI_Trig_IN_7
}
AO Digital trigger source. More...
enum class | JYPXIe9702.AOMode { JYPXIe9702.Finite = JYPXIe9702Import.Finite , JYPXIe9702.ContinuousWrapping = JYPXIe9702Import.ContinuousWrapping , JYPXIe9702.ContinuousNoWrapping = JYPXIe9702Import.Stream , JYPXIe9702.DDS = JYPXIe9702Import.DDS }
AOMode More...
enum class | JYPXIe9702.WaveformType { JYPXIe9702.Sine = JYPXIe9702Import.Sine , JYPXIe9702.Square = JYPXIe9702Import.Square , JYPXIe9702.Triangle = JYPXIe9702Import.Triangle }
DDS waveform type configuration More...
enum class | JYPXIe9702.AOTriggerType { JYPXIe9702.Immediate = JYPXIe9702Import.ImmediateTrigger , JYPXIe9702.Digital = JYPXIe9702Import.DigitalTrigger , JYPXIe9702.Soft = JYPXIe9702Import.SoftTrigger }
TriggerType Digital/Immediate/Soft More...
enum class | JYPXIe9702.AOSignalExportSource { JYPXIe9702.StartTrig = JYPXIe9702Import.AOStartTrigger }
SourceSignal More...
enum class JYPXIe9702.SignalExportDestination {
JYPXIe9702.TRG = JYPXIe9702Import.TriggerOut , JYPXIe9702.PFI0 = JYPXIe9702Import.PFI_Out_0 , JYPXIe9702.PFI1 = JYPXIe9702Import.PFI_Out_1 , JYPXIe9702.PFI2 = JYPXIe9702Import.PFI_Out_2 ,
JYPXIe9702.PFI3 = JYPXIe9702Import.PFI_Out_3 , JYPXIe9702.PFI4 = JYPXIe9702Import.PFI_Out_4 , JYPXIe9702.PFI5 = JYPXIe9702Import.PFI_Out_5 , JYPXIe9702.PFI6 = JYPXIe9702Import.PFI_Out_6 ,
JYPXIe9702.PFI7 = JYPXIe9702Import.PFI_Out_7 , JYPXIe9702.PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , JYPXIe9702.PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , JYPXIe9702.PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
JYPXIe9702.PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , JYPXIe9702.PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , JYPXIe9702.PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , JYPXIe9702.PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
JYPXIe9702.PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
AOSampleClk= AXIS_Clk_OUT,. More...
enum class | JYPXIe9702.SyncTopology { JYPXIe9702.Independent = 0 , JYPXIe9702.Master = 1 , JYPXIe9702.Slave = 3 }
Synchronization board configuration More...
enum class JYPXIe9702.SyncTriggerRouting {
JYPXIe9702.NONE = -1 , JYPXIe9702.PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , JYPXIe9702.PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , JYPXIe9702.PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
JYPXIe9702.PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , JYPXIe9702.PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , JYPXIe9702.PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , JYPXIe9702.PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
JYPXIe9702.PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class JYPXIe9702.SyncPulseRouting {
JYPXIe9702.NONE = -1 , JYPXIe9702.PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , JYPXIe9702.PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , JYPXIe9702.PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
JYPXIe9702.PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , JYPXIe9702.PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , JYPXIe9702.PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , JYPXIe9702.PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
JYPXIe9702.PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...


9702 C# Programming Manual: JYPXIe9702.JYPXIe9702AOTask Class Reference

  • JYPXIe9702
  • JYPXIe9702AOTask
Public Member Functions | Properties | List of all members
JYPXIe9702.JYPXIe9702AOTask Class Reference

JY9702 Analog ouput Task More...

Public Member Functions

JYPXIe9702AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number. More...
JYPXIe9702AOTask (string boardName)
Constructor. More...
void | AddChannel (int chnId, double rangeLow=-5, double rangeHigh=5, double delay=0)
Add one channel. More...
void | AddChannel (int[] chnsId, double rangeLow=-5, double rangeHigh=5, double delay=0)
Add a group of channels. More...
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, double delay=0)
Add a group of channels. More...
void | RemoveChannel (int chnId)
Delete the specified channel number. More...
void | WriteSinglePoint (DDSConfig ddsConfig)
Configure the output waveform parameters. More...
void | WriteSinglePoint (DDSConfig[] ddsConfigs)
Configure the output waveform parameters. More...
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel. More...
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data. More...
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer. More...
void | WriteRawData (short[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel. More...
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data. More...
void | WriteRawData (short[] buf, int timeout=10000)
Write one channel raw Data to AO buffer. More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
void | Start ()
Start AO task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop AO task . More...

Properties

List< AOChannel > | Channels [get]
List of AO channels,(support 2 channels). More...
AOMode | Mode [get, set]
Mode of AO Task. More...
JYPXIe9702Device | Device [get]
Device used by this task. More...
double | UpdateRate [get, set]
Update rate per channel. More...
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Property SamplesToUpdate must be less than or equal to this value. More...
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffer. More...
AOAdvanced | Advanced [get]
AO Advanced Configuration More...
AOTrigger | Trigger [get]
AO Trigger Configuration. More...
AOSignalExport | SignalExport [get]
AO signal export configuration. More...
AISync | Sync [get]
Multi card synchronous configuration More...

Detailed Description

JY9702 Analog ouput Task

Constructor & Destructor Documentation

◆ JYPXIe9702AOTask() [1/2]

JYPXIe9702.JYPXIe9702AOTask.JYPXIe9702AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JYPXIe9702AOTask() [2/2]

JYPXIe9702.JYPXIe9702AOTask.JYPXIe9702AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager.

Member Function Documentation

◆ AddChannel() [1/3]

void JYPXIe9702.JYPXIe9702AOTask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -5,
 |  | double | rangeHigh = 5,
 |  | double | delay = 0
 | ) |  |

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（Support 2 channels）
rangeLow | lower range limit for the channel，-5V,-1.25V ,-0.5V,defalut -5
rangeHigh | higher range limit for the channel，5V,1.25V ,0.5V,defalut 5
delay | The delay of AO channel in nanosecond.

◆ AddChannel() [2/3]

void JYPXIe9702.JYPXIe9702AOTask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -5,
 |  | double | rangeHigh = 5,
 |  | double | delay = 0
 | ) |  |

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers.（Support 2 channels）
rangeLow | lower range limit for the channel，-5V,-1.25V ,-0.5V,defalut -5
rangeHigh | higher range limit for the channel，5V,1.25V ,0.5V,defalut 5
delay | The delay of AO channel in nanosecond.

◆ AddChannel() [3/3]

void JYPXIe9702.JYPXIe9702AOTask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | double | delay = 0
 | ) |  |

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers.（Support 2 channels）
rangeLow | lower range limit for the channel，-5V,-1.25V ,-0.5V,defalut -5
rangeHigh | higher range limit for the channel，5V,1.25V ,0.5V,defalut 5
delay | The delay of AO channel in nanosecond.

◆ RemoveChannel()

void JYPXIe9702.JYPXIe9702AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPXIe9702.JYPXIe9702AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPXIe9702.JYPXIe9702AOTask.Start ( )

Start AO task .

◆ Stop()

void JYPXIe9702.JYPXIe9702AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYPXIe9702.JYPXIe9702AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteRawData | ( | short | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JYPXIe9702.JYPXIe9702AOTask.WriteRawData | ( | short[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JYPXIe9702.JYPXIe9702AOTask.WriteSinglePoint ( DDSConfig ddsConfig )

Configure the output waveform parameters.

This method is only available for DDS mode.

Parameters
ddsConfig DDS waveform configuration.

◆ WriteSinglePoint() [2/2]

void JYPXIe9702.JYPXIe9702AOTask.WriteSinglePoint ( DDSConfig[] ddsConfigs )

Configure the output waveform parameters.

This method is only available for DDS mode.

Parameters
ddsConfigs DDS waveform configuration.

Property Documentation

◆ Advanced

AOAdvanced JYPXIe9702.JYPXIe9702AOTask.Advanced
get

AO Advanced Configuration

◆ AvaliableLenInSamples

uint JYPXIe9702.JYPXIe9702AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffer.

◆ BufLenInSamples

int JYPXIe9702.JYPXIe9702AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Property SamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JYPXIe9702.JYPXIe9702AOTask.Channels
get

List of AO channels,(support 2 channels).

◆ Device

JYPXIe9702Device JYPXIe9702.JYPXIe9702AOTask.Device
get

Device used by this task.

◆ Mode

AOMode JYPXIe9702.JYPXIe9702AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SamplesToUpdate

int JYPXIe9702.JYPXIe9702AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JYPXIe9702.JYPXIe9702AOTask.SignalExport
get

AO signal export configuration.

◆ Sync

AISync JYPXIe9702.JYPXIe9702AOTask.Sync
get

Multi card synchronous configuration

◆ Trigger

AOTrigger JYPXIe9702.JYPXIe9702AOTask.Trigger
get

AO Trigger Configuration.

◆ UpdateRate

double JYPXIe9702.JYPXIe9702AOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 250M for single channel, 125M for two channels. The default sample rate = 50M. You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JYPXIe9702.AOChannel Class Reference

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID. More...
double | RangeLow [get, set]
Low range limit an AO channel. More...
double | RangeHigh [get, set]
High range limit an AO channel. More...
double | Gain [get, set]
The gain of AO channel. More...
double | Delay [get, set]
The delay of channel in nanosecond. More...

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JYPXIe9702.AOChannel.ChannelID
get

AO channel ID.

◆ Delay

double JYPXIe9702.AOChannel.Delay
getset

The delay of channel in nanosecond.

◆ Gain

double JYPXIe9702.AOChannel.Gain
getset

The gain of AO channel.

◆ RangeHigh

double JYPXIe9702.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JYPXIe9702.AOChannel.RangeLow
getset

Low range limit an AO channel.

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.DDSConfig Class Reference

  • DDSConfig
Public Member Functions | Properties | List of all members
JYPXIe9702.DDSConfig Class Reference

DDS waveform configuration class. More...

Public Member Functions

DDSConfig ()
Create a instance of DDS class. More...

Properties

WaveformType | WaveformType [get, set]
Waveform type More...
double | Frequency [get, set]
Waveform frequency More...
double | Amplitude [get, set]
Waveform amplitude More...
double | Offset [get, set]
Waveform offset in voltage. More...
double | DutyCycle [get, set]
The duty cycle of waveform. More...
double | PhaseOffset [get, set]
The initial phase of waveform More...
double | PhaseCompare [get, set]
The output voltage threshold for the high level output of Sync pin. More...

Detailed Description

DDS waveform configuration class.

Constructor & Destructor Documentation

◆ DDSConfig()

JYPXIe9702.DDSConfig.DDSConfig ( )

Create a instance of DDS class.

Property Documentation

◆ Amplitude

double JYPXIe9702.DDSConfig.Amplitude
getset

Waveform amplitude

◆ DutyCycle

double JYPXIe9702.DDSConfig.DutyCycle
getset

The duty cycle of waveform.

This property is only available for square wave and triangle wave.

◆ Frequency

double JYPXIe9702.DDSConfig.Frequency
getset

Waveform frequency

◆ Offset

double JYPXIe9702.DDSConfig.Offset
getset

Waveform offset in voltage.

◆ PhaseCompare

double JYPXIe9702.DDSConfig.PhaseCompare
getset

The output voltage threshold for the high level output of Sync pin.

◆ PhaseOffset

double JYPXIe9702.DDSConfig.PhaseOffset
getset

The initial phase of waveform

◆ WaveformType

WaveformType JYPXIe9702.DDSConfig.WaveformType
getset

Waveform type

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AOAdvanced Class Reference

  • AOAdvanced
Properties | List of all members
JYPXIe9702.AOAdvanced Class Reference

AO Advanced parameters More...

Properties

bool | EnableInverseSinc [get, set]
Whether enable InverseSinc filter More...
bool | EnableInterpolation [get, set]
Whether enable interpolation function. More...
bool | EnableOverflowProtection [get, set]
Whether enable overflow protection. More...
bool | EnableBasebandMode [get, set]
Whether enable baseband mode. More...
double | CenterFrequency [get, set]
DUC Center Frequency More...

Detailed Description

AO Advanced parameters

Property Documentation

◆ CenterFrequency

double JYPXIe9702.AOAdvanced.CenterFrequency
getset

DUC Center Frequency

◆ EnableBasebandMode

bool JYPXIe9702.AOAdvanced.EnableBasebandMode
getset

Whether enable baseband mode.

◆ EnableInterpolation

bool JYPXIe9702.AOAdvanced.EnableInterpolation
getset

Whether enable interpolation function.

◆ EnableInverseSinc

bool JYPXIe9702.AOAdvanced.EnableInverseSinc
getset

Whether enable InverseSinc filter

◆ EnableOverflowProtection

bool JYPXIe9702.AOAdvanced.EnableOverflowProtection
getset

Whether enable overflow protection.

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JYPXIe9702.AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type. More...
AODigitalTrigger | Digital [get, set]
AO Digital Trigger. More...

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JYPXIe9702.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYPXIe9702.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JYPXIe9702.AODigitalTrigger Class Reference

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source. More...
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JYPXIe9702.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYPXIe9702.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JYPXIe9702.AOSignalExport Class Reference

AO Signal Export Class More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to multi-destination More...
void | ClearAll ()
Clear all Signal Export More...

Detailed Description

AO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JYPXIe9702.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to multi-destination

Parameters
source | AO Signal Source
destinations | Mutil Export Desination

◆ Add() [2/2]

void JYPXIe9702.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AO Signal Source
destination | Export Desination

◆ ClearAll()

void JYPXIe9702.AOSignalExport.ClearAll ( )

Clear all Signal Export

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: JYPXIe9702.AISync Class Reference

  • AISync
Public Member Functions | Properties | List of all members
JYPXIe9702.AISync Class Reference

Configure sync signal More...

Public Member Functions

void Commit ()
commit sync config More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal More...
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0 More...
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1 More...

Detailed Description

Configure sync signal

Member Function Documentation

◆ Commit()

void JYPXIe9702.AISync.Commit ( )

commit sync config

Property Documentation

◆ PulseRouting

SyncPulseRouting JYPXIe9702.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1

◆ Topology

SyncTopology JYPXIe9702.AISync.Topology
getset

Configure sync signal

◆ TriggerRouting

SyncTriggerRouting JYPXIe9702.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702AOTask.cs


9702 C# Programming Manual: D:/9702/C#/JYPXIe9702DITask.cs File Reference

Classes | Namespaces
JYPXIe9702DITask.cs File Reference

Classes

class | JYPXIe9702.JYPXIe9702DITask
JYPXIe9702DITask Class More...
class | JYPXIe9702.DIChannel
DI Channel parameter class More...

Namespaces

namespace JYPXIe9702


9702 C# Programming Manual: JYPXIe9702.JYPXIe9702DITask Class Reference

  • JYPXIe9702DITask
Public Member Functions | Properties | List of all members
JYPXIe9702.JYPXIe9702DITask Class Reference

JYPXIe9702DITask Class More...

Public Member Functions

JYPXIe9702DITask (int slotNum)
Constructor. More...
JYPXIe9702DITask (string aliasName)
Constructor. More...
void | AddChannel (int lineNum)
Add one line More...
void | AddChannel (int[] linesNum)
Add a group of line More...
void | RemoveChannel (int lineNum)
Delete the specified line number More...
void | Start ()
Start DITask More...
void | Stop ()
Stop DITask More...
void | ReadSinglePoint (ref bool readValue, int lineNum)
Specify the line reads the latest point More...
void | ReadSinglePoint (ref bool[] buf)
Each line reads the latest point More...

Properties

JYPXIe9702Device | Device [get]
Device Handle More...
List< DIChannel > | Channels [get]
List of DI channels More...

Detailed Description

JYPXIe9702DITask Class

Constructor & Destructor Documentation

◆ JYPXIe9702DITask() [1/2]

JYPXIe9702.JYPXIe9702DITask.JYPXIe9702DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JYPXIe9702DITask() [2/2]

JYPXIe9702.JYPXIe9702DITask.JYPXIe9702DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JYPXIe9702.JYPXIe9702DITask.AddChannel ( int lineNum )

Add one line

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JYPXIe9702.JYPXIe9702DITask.AddChannel ( int[] linesNum )

Add a group of line

Parameters
linesNum lines number

◆ ReadSinglePoint() [1/2]

void JYPXIe9702.JYPXIe9702DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | lineNum
 | ) |  |

Specify the line reads the latest point

Parameters
readValue | read Value
lineNum | Specify the line to read

◆ ReadSinglePoint() [2/2]

void JYPXIe9702.JYPXIe9702DITask.ReadSinglePoint ( ref bool[] buf )

Each line reads the latest point

Parameters
buf User buffer array

◆ RemoveChannel()

void JYPXIe9702.JYPXIe9702DITask.RemoveChannel ( int lineNum )

Delete the specified line number

Parameters
lineNum line number

◆ Start()

void JYPXIe9702.JYPXIe9702DITask.Start ( )

Start DITask

◆ Stop()

void JYPXIe9702.JYPXIe9702DITask.Stop ( )

Stop DITask

Property Documentation

◆ Channels

List<DIChannel> JYPXIe9702.JYPXIe9702DITask.Channels
get

List of DI channels

◆ Device

JYPXIe9702Device JYPXIe9702.JYPXIe9702DITask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702DITask.cs


9702 C# Programming Manual: JYPXIe9702.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYPXIe9702.DIChannel Class Reference

DI Channel parameter class More...

Properties

int LineNum [get, set]
Line Number More...

Detailed Description

DI Channel parameter class

Property Documentation

◆ LineNum

int JYPXIe9702.DIChannel.LineNum
getset

Line Number

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702DITask.cs


9702 C# Programming Manual: D:/9702/C#/JYPXIe9702DOTask.cs File Reference

Classes | Namespaces
JYPXIe9702DOTask.cs File Reference

Classes

class | JYPXIe9702.JYPXIe9702DOTask
JYPXIe9702 DOTask More...
class | JYPXIe9702.DOChannel
DOChannel class More...

Namespaces

namespace JYPXIe9702


9702 C# Programming Manual: JYPXIe9702.JYPXIe9702DOTask Class Reference

  • JYPXIe9702DOTask
Public Member Functions | Properties | List of all members
JYPXIe9702.JYPXIe9702DOTask Class Reference

JYPXIe9702 DOTask More...

Public Member Functions

JYPXIe9702DOTask (int slotNum)
Constructor. More...
JYPXIe9702DOTask (string aliasName)
Constructor. More...
void | AddChannel (int lineNum)
Add one line More...
void | AddChannel (int[] linesNum)
Add mulitiple lines More...
void | RemoveChannel (int lineNum)
delete the specified line number More...
void | Start ()
Start DOTask More...
void | Stop ()
Stop DOTask More...
void | WriteSinglePoint (bool writeValue, int lineNum)
write the latest point of Specify line More...
void | WriteSinglePoint (bool[] writeValues)
write the latest point More...

Properties

JYPXIe9702Device | Device [get]
Device Handle More...
List< DOChannel > | Channels [get]
List of DO channels More...

Detailed Description

JYPXIe9702 DOTask

Constructor & Destructor Documentation

◆ JYPXIe9702DOTask() [1/2]

JYPXIe9702.JYPXIe9702DOTask.JYPXIe9702DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JYPXIe9702DOTask() [2/2]

JYPXIe9702.JYPXIe9702DOTask.JYPXIe9702DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JYPXIe9702.JYPXIe9702DOTask.AddChannel ( int lineNum )

Add one line

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JYPXIe9702.JYPXIe9702DOTask.AddChannel ( int[] linesNum )

Add mulitiple lines

Parameters
linesNum lines number

◆ RemoveChannel()

void JYPXIe9702.JYPXIe9702DOTask.RemoveChannel ( int lineNum )

delete the specified line number

Parameters
lineNum line number

◆ Start()

void JYPXIe9702.JYPXIe9702DOTask.Start ( )

Start DOTask

◆ Stop()

void JYPXIe9702.JYPXIe9702DOTask.Stop ( )

Stop DOTask

◆ WriteSinglePoint() [1/2]

void JYPXIe9702.JYPXIe9702DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | lineNum
 | ) |  |

write the latest point of Specify line

Parameters
writeValue | write Value
lineNum | Specify the line to write

◆ WriteSinglePoint() [2/2]

void JYPXIe9702.JYPXIe9702DOTask.WriteSinglePoint ( bool[] writeValues )

write the latest point

Parameters
writeValues User buffer array

Property Documentation

◆ Channels

List<DOChannel> JYPXIe9702.JYPXIe9702DOTask.Channels
get

List of DO channels

◆ Device

JYPXIe9702Device JYPXIe9702.JYPXIe9702DOTask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702DOTask.cs


9702 C# Programming Manual: JYPXIe9702.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYPXIe9702.DOChannel Class Reference

DOChannel class More...

Properties

int LineNum [get, set]
line Number More...

Detailed Description

DOChannel class

Property Documentation

◆ LineNum

int JYPXIe9702.DOChannel.LineNum
getset

line Number

The documentation for this class was generated from the following file:
  • D:/9702/C#/JYPXIe9702DOTask.cs


9702 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYPXIe9702 |
C JYPXIe9702AOTask | JY9702 Analog ouput Task
C AOChannel | AO Channel parameter class
C DDSConfig | DDS waveform configuration class
C AOAdvanced | AO Advanced parameters
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C AISync | Configure sync signal
C JYPXIe9702DITask | JYPXIe9702DITask Class
C DIChannel | DI Channel parameter class
C JYPXIe9702DOTask | JYPXIe9702 DOTask
C DOChannel | DOChannel class


9702 C# Programming Manual: Member List

  • AISync
JYPXIe9702.AISync Member List

This is the complete list of members for JYPXIe9702.AISync, including all inherited members.

Commit() | JYPXIe9702.AISync
PulseRouting | JYPXIe9702.AISync
Topology | JYPXIe9702.AISync
TriggerRouting | JYPXIe9702.AISync


9702 C# Programming Manual: Member List

  • AOAdvanced
JYPXIe9702.AOAdvanced Member List

This is the complete list of members for JYPXIe9702.AOAdvanced, including all inherited members.

CenterFrequency | JYPXIe9702.AOAdvanced
EnableBasebandMode | JYPXIe9702.AOAdvanced
EnableInterpolation | JYPXIe9702.AOAdvanced
EnableInverseSinc | JYPXIe9702.AOAdvanced
EnableOverflowProtection | JYPXIe9702.AOAdvanced


9702 C# Programming Manual: Member List

  • AOChannel
JYPXIe9702.AOChannel Member List

This is the complete list of members for JYPXIe9702.AOChannel, including all inherited members.

ChannelID | JYPXIe9702.AOChannel
Delay | JYPXIe9702.AOChannel
Gain | JYPXIe9702.AOChannel
RangeHigh | JYPXIe9702.AOChannel
RangeLow | JYPXIe9702.AOChannel


9702 C# Programming Manual: Member List

  • AODigitalTrigger
JYPXIe9702.AODigitalTrigger Member List

This is the complete list of members for JYPXIe9702.AODigitalTrigger, including all inherited members.

Edge | JYPXIe9702.AODigitalTrigger
Source | JYPXIe9702.AODigitalTrigger


9702 C# Programming Manual: Member List

  • AOSignalExport
JYPXIe9702.AOSignalExport Member List

This is the complete list of members for JYPXIe9702.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JYPXIe9702.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JYPXIe9702.AOSignalExport
ClearAll() | JYPXIe9702.AOSignalExport


9702 C# Programming Manual: Member List

  • AOTrigger
JYPXIe9702.AOTrigger Member List

This is the complete list of members for JYPXIe9702.AOTrigger, including all inherited members.

Digital | JYPXIe9702.AOTrigger
Type | JYPXIe9702.AOTrigger


9702 C# Programming Manual: Member List

  • DDSConfig
JYPXIe9702.DDSConfig Member List

This is the complete list of members for JYPXIe9702.DDSConfig, including all inherited members.

Amplitude | JYPXIe9702.DDSConfig
DDSConfig() | JYPXIe9702.DDSConfig
DutyCycle | JYPXIe9702.DDSConfig
Frequency | JYPXIe9702.DDSConfig
Offset | JYPXIe9702.DDSConfig
PhaseCompare | JYPXIe9702.DDSConfig
PhaseOffset | JYPXIe9702.DDSConfig
WaveformType | JYPXIe9702.DDSConfig


9702 C# Programming Manual: Member List

  • DIChannel
JYPXIe9702.DIChannel Member List

This is the complete list of members for JYPXIe9702.DIChannel, including all inherited members.

LineNum JYPXIe9702.DIChannel


9702 C# Programming Manual: Member List

  • DOChannel
JYPXIe9702.DOChannel Member List

This is the complete list of members for JYPXIe9702.DOChannel, including all inherited members.

LineNum JYPXIe9702.DOChannel


9702 C# Programming Manual: Member List

  • JYPXIe9702AOTask
JYPXIe9702.JYPXIe9702AOTask Member List

This is the complete list of members for JYPXIe9702.JYPXIe9702AOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-5, double rangeHigh=5, double delay=0) | JYPXIe9702.JYPXIe9702AOTask
AddChannel(int[] chnsId, double rangeLow=-5, double rangeHigh=5, double delay=0) | JYPXIe9702.JYPXIe9702AOTask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, double delay=0) | JYPXIe9702.JYPXIe9702AOTask
Advanced | JYPXIe9702.JYPXIe9702AOTask
AvaliableLenInSamples | JYPXIe9702.JYPXIe9702AOTask
BufLenInSamples | JYPXIe9702.JYPXIe9702AOTask
Channels | JYPXIe9702.JYPXIe9702AOTask
Device | JYPXIe9702.JYPXIe9702AOTask
JYPXIe9702AOTask(int slotNum) | JYPXIe9702.JYPXIe9702AOTask
JYPXIe9702AOTask(string boardName) | JYPXIe9702.JYPXIe9702AOTask
Mode | JYPXIe9702.JYPXIe9702AOTask
RemoveChannel(int chnId) | JYPXIe9702.JYPXIe9702AOTask
SamplesToUpdate | JYPXIe9702.JYPXIe9702AOTask
SendSoftwareTrigger() | JYPXIe9702.JYPXIe9702AOTask
SignalExport | JYPXIe9702.JYPXIe9702AOTask
Start() | JYPXIe9702.JYPXIe9702AOTask
Stop() | JYPXIe9702.JYPXIe9702AOTask
Sync | JYPXIe9702.JYPXIe9702AOTask
Trigger | JYPXIe9702.JYPXIe9702AOTask
UpdateRate | JYPXIe9702.JYPXIe9702AOTask
WaitUntilDone(int timeout=-1) | JYPXIe9702.JYPXIe9702AOTask
WriteData(double[,] buf, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteData(double[] buf, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteRawData(short[,] buf, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteRawData(short[] buf, int timeout=10000) | JYPXIe9702.JYPXIe9702AOTask
WriteSinglePoint(DDSConfig ddsConfig) | JYPXIe9702.JYPXIe9702AOTask
WriteSinglePoint(DDSConfig[] ddsConfigs) | JYPXIe9702.JYPXIe9702AOTask


9702 C# Programming Manual: Member List

  • JYPXIe9702DITask
JYPXIe9702.JYPXIe9702DITask Member List

This is the complete list of members for JYPXIe9702.JYPXIe9702DITask, including all inherited members.

AddChannel(int lineNum) | JYPXIe9702.JYPXIe9702DITask
AddChannel(int[] linesNum) | JYPXIe9702.JYPXIe9702DITask
Channels | JYPXIe9702.JYPXIe9702DITask
Device | JYPXIe9702.JYPXIe9702DITask
JYPXIe9702DITask(int slotNum) | JYPXIe9702.JYPXIe9702DITask
JYPXIe9702DITask(string aliasName) | JYPXIe9702.JYPXIe9702DITask
ReadSinglePoint(ref bool readValue, int lineNum) | JYPXIe9702.JYPXIe9702DITask
ReadSinglePoint(ref bool[] buf) | JYPXIe9702.JYPXIe9702DITask
RemoveChannel(int lineNum) | JYPXIe9702.JYPXIe9702DITask
Start() | JYPXIe9702.JYPXIe9702DITask
Stop() | JYPXIe9702.JYPXIe9702DITask


9702 C# Programming Manual: Member List

  • JYPXIe9702DOTask
JYPXIe9702.JYPXIe9702DOTask Member List

This is the complete list of members for JYPXIe9702.JYPXIe9702DOTask, including all inherited members.

AddChannel(int lineNum) | JYPXIe9702.JYPXIe9702DOTask
AddChannel(int[] linesNum) | JYPXIe9702.JYPXIe9702DOTask
Channels | JYPXIe9702.JYPXIe9702DOTask
Device | JYPXIe9702.JYPXIe9702DOTask
JYPXIe9702DOTask(int slotNum) | JYPXIe9702.JYPXIe9702DOTask
JYPXIe9702DOTask(string aliasName) | JYPXIe9702.JYPXIe9702DOTask
RemoveChannel(int lineNum) | JYPXIe9702.JYPXIe9702DOTask
Start() | JYPXIe9702.JYPXIe9702DOTask
Stop() | JYPXIe9702.JYPXIe9702DOTask
WriteSinglePoint(bool writeValue, int lineNum) | JYPXIe9702.JYPXIe9702DOTask
WriteSinglePoint(bool[] writeValues) | JYPXIe9702.JYPXIe9702DOTask


9702 C# Programming Manual: Class Index

Class Index
A | D | J
A
AISync (JYPXIe9702)
AOAdvanced (JYPXIe9702)
AOChannel (JYPXIe9702)
AODigitalTrigger (JYPXIe9702)
AOSignalExport (JYPXIe9702)
AOTrigger (JYPXIe9702)
D
DDSConfig (JYPXIe9702)
DIChannel (JYPXIe9702)
DOChannel (JYPXIe9702)
J
JYPXIe9702AOTask (JYPXIe9702)
JYPXIe9702DITask (JYPXIe9702)
JYPXIe9702DOTask (JYPXIe9702)


9702 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 9702


9702 C# Programming Manual: D:/9702 Directory Reference

  • D:
  • 9702
9702 Directory Reference

Directories

directory C#


9702 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 9702
▼ C#
JYPXIe9702AOTask.cs
JYPXIe9702DITask.cs
JYPXIe9702DOTask.cs


9702 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JYPXIe9702.AOSignalExport
  • AddChannel() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Advanced : JYPXIe9702.JYPXIe9702AOTask
  • Amplitude : JYPXIe9702.DDSConfig
  • AvaliableLenInSamples : JYPXIe9702.JYPXIe9702AOTask

- b -

  • BufLenInSamples : JYPXIe9702.JYPXIe9702AOTask

- c -

  • CenterFrequency : JYPXIe9702.AOAdvanced
  • ChannelID : JYPXIe9702.AOChannel
  • Channels : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • ClearAll() : JYPXIe9702.AOSignalExport
  • Commit() : JYPXIe9702.AISync

- d -

  • DDSConfig() : JYPXIe9702.DDSConfig
  • Delay : JYPXIe9702.AOChannel
  • Device : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Digital : JYPXIe9702.AOTrigger
  • DutyCycle : JYPXIe9702.DDSConfig

- e -

  • Edge : JYPXIe9702.AODigitalTrigger
  • EnableBasebandMode : JYPXIe9702.AOAdvanced
  • EnableInterpolation : JYPXIe9702.AOAdvanced
  • EnableInverseSinc : JYPXIe9702.AOAdvanced
  • EnableOverflowProtection : JYPXIe9702.AOAdvanced

- f -

  • Frequency : JYPXIe9702.DDSConfig

- g -

  • Gain : JYPXIe9702.AOChannel

- j -

  • JYPXIe9702AOTask() : JYPXIe9702.JYPXIe9702AOTask
  • JYPXIe9702DITask() : JYPXIe9702.JYPXIe9702DITask
  • JYPXIe9702DOTask() : JYPXIe9702.JYPXIe9702DOTask

- l -

  • LineNum : JYPXIe9702.DIChannel , JYPXIe9702.DOChannel

- m -

  • Mode : JYPXIe9702.JYPXIe9702AOTask

- o -

  • Offset : JYPXIe9702.DDSConfig

- p -

  • PhaseCompare : JYPXIe9702.DDSConfig
  • PhaseOffset : JYPXIe9702.DDSConfig
  • PulseRouting : JYPXIe9702.AISync

- r -

  • RangeHigh : JYPXIe9702.AOChannel
  • RangeLow : JYPXIe9702.AOChannel
  • ReadSinglePoint() : JYPXIe9702.JYPXIe9702DITask
  • RemoveChannel() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask

- s -

  • SamplesToUpdate : JYPXIe9702.JYPXIe9702AOTask
  • SendSoftwareTrigger() : JYPXIe9702.JYPXIe9702AOTask
  • SignalExport : JYPXIe9702.JYPXIe9702AOTask
  • Source : JYPXIe9702.AODigitalTrigger
  • Start() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Stop() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Sync : JYPXIe9702.JYPXIe9702AOTask

- t -

  • Topology : JYPXIe9702.AISync
  • Trigger : JYPXIe9702.JYPXIe9702AOTask
  • TriggerRouting : JYPXIe9702.AISync
  • Type : JYPXIe9702.AOTrigger

- u -

  • UpdateRate : JYPXIe9702.JYPXIe9702AOTask

- w -

  • WaitUntilDone() : JYPXIe9702.JYPXIe9702AOTask
  • WaveformType : JYPXIe9702.DDSConfig
  • WriteData() : JYPXIe9702.JYPXIe9702AOTask
  • WriteRawData() : JYPXIe9702.JYPXIe9702AOTask
  • WriteSinglePoint() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DOTask


9702 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JYPXIe9702.AOSignalExport
  • AddChannel() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask

- c -

  • ClearAll() : JYPXIe9702.AOSignalExport
  • Commit() : JYPXIe9702.AISync

- d -

  • DDSConfig() : JYPXIe9702.DDSConfig

- j -

  • JYPXIe9702AOTask() : JYPXIe9702.JYPXIe9702AOTask
  • JYPXIe9702DITask() : JYPXIe9702.JYPXIe9702DITask
  • JYPXIe9702DOTask() : JYPXIe9702.JYPXIe9702DOTask

- r -

  • ReadSinglePoint() : JYPXIe9702.JYPXIe9702DITask
  • RemoveChannel() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask

- s -

  • SendSoftwareTrigger() : JYPXIe9702.JYPXIe9702AOTask
  • Start() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Stop() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask

- w -

  • WaitUntilDone() : JYPXIe9702.JYPXIe9702AOTask
  • WriteData() : JYPXIe9702.JYPXIe9702AOTask
  • WriteRawData() : JYPXIe9702.JYPXIe9702AOTask
  • WriteSinglePoint() : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DOTask


9702 C# Programming Manual: Class Members - Properties

- a -

  • Advanced : JYPXIe9702.JYPXIe9702AOTask
  • Amplitude : JYPXIe9702.DDSConfig
  • AvaliableLenInSamples : JYPXIe9702.JYPXIe9702AOTask

- b -

  • BufLenInSamples : JYPXIe9702.JYPXIe9702AOTask

- c -

  • CenterFrequency : JYPXIe9702.AOAdvanced
  • ChannelID : JYPXIe9702.AOChannel
  • Channels : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask

- d -

  • Delay : JYPXIe9702.AOChannel
  • Device : JYPXIe9702.JYPXIe9702AOTask , JYPXIe9702.JYPXIe9702DITask , JYPXIe9702.JYPXIe9702DOTask
  • Digital : JYPXIe9702.AOTrigger
  • DutyCycle : JYPXIe9702.DDSConfig

- e -

  • Edge : JYPXIe9702.AODigitalTrigger
  • EnableBasebandMode : JYPXIe9702.AOAdvanced
  • EnableInterpolation : JYPXIe9702.AOAdvanced
  • EnableInverseSinc : JYPXIe9702.AOAdvanced
  • EnableOverflowProtection : JYPXIe9702.AOAdvanced

- f -

  • Frequency : JYPXIe9702.DDSConfig

- g -

  • Gain : JYPXIe9702.AOChannel

- l -

  • LineNum : JYPXIe9702.DIChannel , JYPXIe9702.DOChannel

- m -

  • Mode : JYPXIe9702.JYPXIe9702AOTask

- o -

  • Offset : JYPXIe9702.DDSConfig

- p -

  • PhaseCompare : JYPXIe9702.DDSConfig
  • PhaseOffset : JYPXIe9702.DDSConfig
  • PulseRouting : JYPXIe9702.AISync

- r -

  • RangeHigh : JYPXIe9702.AOChannel
  • RangeLow : JYPXIe9702.AOChannel

- s -

  • SamplesToUpdate : JYPXIe9702.JYPXIe9702AOTask
  • SignalExport : JYPXIe9702.JYPXIe9702AOTask
  • Source : JYPXIe9702.AODigitalTrigger
  • Sync : JYPXIe9702.JYPXIe9702AOTask

- t -

  • Topology : JYPXIe9702.AISync
  • Trigger : JYPXIe9702.JYPXIe9702AOTask
  • TriggerRouting : JYPXIe9702.AISync
  • Type : JYPXIe9702.AOTrigger

- u -

  • UpdateRate : JYPXIe9702.JYPXIe9702AOTask

- w -

  • WaveformType : JYPXIe9702.DDSConfig


9702 C# Programming Manual: Main Page

9702 C# Programming Manual Documentation


9702 C# Programming Manual: JYPXIe9702 Namespace Reference

Classes | Enumerations
JYPXIe9702 Namespace Reference

Classes

class | JYPXIe9702AOTask
JY9702 Analog ouput Task More...
class | AOChannel
AO Channel parameter class . More...
class | DDSConfig
DDS waveform configuration class. More...
class | AOAdvanced
AO Advanced parameters More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class More...
class | AISync
Configure sync signal More...
class | JYPXIe9702DITask
JYPXIe9702DITask Class More...
class | DIChannel
DI Channel parameter class More...
class | JYPXIe9702DOTask
JYPXIe9702 DOTask More...
class | DOChannel
DOChannel class More...

Enumerations

enum class | AODigitalTriggerEdge { Rising = JYPXIe9702Import.Rising_Edge_Trigger , Falling = JYPXIe9702Import.Falling_Edge_Trigger , High = JYPXIe9702Import.High_Level_Trigger , Low = JYPXIe9702Import.Low_Level_Trigger }
AO Digital Trigger Edge More...
enum class AODigitalTriggerSource {
TRIG_IN = JYPXIe9702Import.TriggerIn , PFI0 = JYPXIe9702Import.PFI_0_IN_0 , PFI1 = JYPXIe9702Import.PFI_0_IN_1 , PFI2 = JYPXIe9702Import.PFI_0_IN_2 ,
PFI3 = JYPXIe9702Import.PFI_0_IN_3 , PFI4 = JYPXIe9702Import.PFI_0_IN_4 , PFI5 = JYPXIe9702Import.PFI_0_IN_5 , PFI6 = JYPXIe9702Import.PFI_0_IN_6 ,
PFI7 = JYPXIe9702Import.PFI_0_IN_7 , PXI_Trig0 = JYPXIe9702Import.PFI_PXI_Trig_IN_0 , PXI_Trig1 = JYPXIe9702Import.PFI_PXI_Trig_IN_1 , PXI_Trig2 = JYPXIe9702Import.PFI_PXI_Trig_IN_2 ,
PXI_Trig3 = JYPXIe9702Import.PFI_PXI_Trig_IN_3 , PXI_Trig4 = JYPXIe9702Import.PFI_PXI_Trig_IN_4 , PXI_Trig5 = JYPXIe9702Import.PFI_PXI_Trig_IN_5 , PXI_Trig6 = JYPXIe9702Import.PFI_PXI_Trig_IN_6 ,
PXI_Trig7 = JYPXIe9702Import.PFI_PXI_Trig_IN_7
}
AO Digital trigger source. More...
enum class | AOMode { Finite = JYPXIe9702Import.Finite , ContinuousWrapping = JYPXIe9702Import.ContinuousWrapping , ContinuousNoWrapping = JYPXIe9702Import.Stream , DDS = JYPXIe9702Import.DDS }
AOMode More...
enum class | WaveformType { Sine = JYPXIe9702Import.Sine , Square = JYPXIe9702Import.Square , Triangle = JYPXIe9702Import.Triangle }
DDS waveform type configuration More...
enum class | AOTriggerType { Immediate = JYPXIe9702Import.ImmediateTrigger , Digital = JYPXIe9702Import.DigitalTrigger , Soft = JYPXIe9702Import.SoftTrigger }
TriggerType Digital/Immediate/Soft More...
enum class | AOSignalExportSource { StartTrig = JYPXIe9702Import.AOStartTrigger }
SourceSignal More...
enum class SignalExportDestination {
TRG = JYPXIe9702Import.TriggerOut , PFI0 = JYPXIe9702Import.PFI_Out_0 , PFI1 = JYPXIe9702Import.PFI_Out_1 , PFI2 = JYPXIe9702Import.PFI_Out_2 ,
PFI3 = JYPXIe9702Import.PFI_Out_3 , PFI4 = JYPXIe9702Import.PFI_Out_4 , PFI5 = JYPXIe9702Import.PFI_Out_5 , PFI6 = JYPXIe9702Import.PFI_Out_6 ,
PFI7 = JYPXIe9702Import.PFI_Out_7 , PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
AOSampleClk= AXIS_Clk_OUT,. More...
enum class | SyncTopology { Independent = 0 , Master = 1 , Slave = 3 }
Synchronization board configuration More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JYPXIe9702Import.PXI_Trig_Out0 , PXI_Trig1 = JYPXIe9702Import.PXI_Trig_Out1 , PXI_Trig2 = JYPXIe9702Import.PXI_Trig_Out2 ,
PXI_Trig3 = JYPXIe9702Import.PXI_Trig_Out3 , PXI_Trig4 = JYPXIe9702Import.PXI_Trig_Out4 , PXI_Trig5 = JYPXIe9702Import.PXI_Trig_Out5 , PXI_Trig6 = JYPXIe9702Import.PXI_Trig_Out6 ,
PXI_Trig7 = JYPXIe9702Import.PXI_Trig_Out7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...

Enumeration Type Documentation

◆ AODigitalTriggerEdge

enum JYPXIe9702.AODigitalTriggerEdge
strong

AO Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge
High | High level trigger
Low | Low level trigger

◆ AODigitalTriggerSource

enum JYPXIe9702.AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
TRIG_IN | PFI0
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PFI3 | PFI3
PFI4 | PFI4
PFI5 | PFI5
PFI6 | PFI6
PFI7 | PFI7
PXI_Trig0 | PXI trigger in 0
PXI_Trig1 | PXI trigger in 1
PXI_Trig2 | PXI trigger in 2
PXI_Trig3 | PXI trigger in 3
PXI_Trig4 | PXI trigger in 4
PXI_Trig5 | PXI trigger in 5
PXI_Trig6 | PXI trigger in 6
PXI_Trig7 | PXI trigger in 7

◆ AOMode

enum JYPXIe9702.AOMode
strong

AOMode

Enumerator
Finite | Finite
ContinuousWrapping | ContinuousWrapping
ContinuousNoWrapping | ContinuousNoWrapping
DDS | Direct Digital Synthesis

◆ AOSignalExportSource

enum JYPXIe9702.AOSignalExportSource
strong

SourceSignal

Enumerator
StartTrig

AOReadyForStartTrigger

AOStartTrigger

◆ AOTriggerType

enum JYPXIe9702.AOTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ SignalExportDestination

enum JYPXIe9702.SignalExportDestination
strong

AOSampleClk= AXIS_Clk_OUT,.

Standard_Waveform_sync_ch0Output DestinationTerminal Standard_Waveform_sync_ch1

Enumerator
TRG | TRG
PFI0 | PFI_Out_0
PFI1 | PFI_Out_1
PFI2 | PFI_Out_2
PFI3 | PFI_Out_3
PFI4 | PFI_Out_4
PFI5 | PFI_Out_5
PFI6 | PFI_Out_6
PFI7 | PFI_Out_7
PXI_Trig0 | PXI_Trig_Out0
PXI_Trig1 | PXI_Trig_Out1
PXI_Trig2 | PXI_Trig_Out2
PXI_Trig3 | PXI_Trig_Out3
PXI_Trig4 | PXI_Trig_Out4
PXI_Trig5 | PXI_Trig_Out5
PXI_Trig6 | PXI_Trig_Out6
PXI_Trig7 | PXI_Trig_Out7

◆ SyncPulseRouting

enum JYPXIe9702.SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI_Trig_Out0
PXI_Trig1 | PXI_Trig_Out1
PXI_Trig2 | PXI_Trig_Out2
PXI_Trig3 | PXI_Trig_Out3
PXI_Trig4 | PXI_Trig_Out4
PXI_Trig5 | PXI_Trig_Out5
PXI_Trig6 | PXI_Trig_Out6
PXI_Trig7 | PXI_Trig_Out7

◆ SyncTopology

enum JYPXIe9702.SyncTopology
strong

Synchronization board configuration

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JYPXIe9702.SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trigt4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7

◆ WaveformType

enum JYPXIe9702.WaveformType
strong

DDS waveform type configuration

Enumerator
Sine | Sine wave
Square | Square wave
Triangle | Triangle wave


9702 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • AODigitalTriggerEdge : JYPXIe9702
  • AODigitalTriggerSource : JYPXIe9702
  • AOMode : JYPXIe9702
  • AOSignalExportSource : JYPXIe9702
  • AOTriggerType : JYPXIe9702
  • SignalExportDestination : JYPXIe9702
  • SyncPulseRouting : JYPXIe9702
  • SyncTopology : JYPXIe9702
  • SyncTriggerRouting : JYPXIe9702
  • WaveformType : JYPXIe9702


9702 C# Programming Manual: Package Functions

  • AODigitalTriggerEdge : JYPXIe9702
  • AODigitalTriggerSource : JYPXIe9702
  • AOMode : JYPXIe9702
  • AOSignalExportSource : JYPXIe9702
  • AOTriggerType : JYPXIe9702
  • SignalExportDestination : JYPXIe9702
  • SyncPulseRouting : JYPXIe9702
  • SyncTopology : JYPXIe9702
  • SyncTriggerRouting : JYPXIe9702
  • WaveformType : JYPXIe9702


9702 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JYPXIe9702 |
C JYPXIe9702AOTask | JY9702 Analog ouput Task
C AOChannel | AO Channel parameter class
C DDSConfig | DDS waveform configuration class
C AOAdvanced | AO Advanced parameters
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C AISync | Configure sync signal
C JYPXIe9702DITask | JYPXIe9702DITask Class
C DIChannel | DI Channel parameter class
C JYPXIe9702DOTask | JYPXIe9702 DOTask
C DOChannel | DOChannel class